MongoDB 설치 오류 질문


  • Level 3

    MongoDB를 설치하려고 하는데 계속해서

    dpkg: error processing package mongodb-org (--configure):
      dependency problems - leaving unconfigured
    Errors were encountered while processing:
      mongodb-org-server
      mongodb-org
    

    라는 오류가 생깁니다. 컨테이너를 생성할 때 MongDB 옵션을 선택해도 해당 오류가 나면서 제대로 설치가 되지 않고, goorm blog에 있는

    apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv 9DA31620334BD75D9DCB49F368818C72E52529D4 && (echo "deb [ arch=amd64 ] https://repo.mongodb.org/apt/ubuntu bionic/mongodb-org/4.0 multiverse" | tee /etc/apt/sources.list.d/mongodb-org-4.0.list) && apt-get update && apt-get install -y mongodb-org && mkdir -p /data/db
    

    로 설치를 진행해도 같은 오류가 발생합니다.

    혹시 이런 상황이 발생하고 해결하신 분 계신가요??

  • Level 1

    저도 똑같은 오류가 뜹니다..

  • Level 3

    해결했습니다.

    혹시 같은 증상을 겪는 분이 계실지도 몰라서 올립니다.

    > sudo rm /var/lib/dpkg/info/*
    > sudo dpkg --configure -a
    > sudo apt-get update
    > sudo apt-get upgrade
    

    를 하니 정상적으로 설치됩니다.

SUGGESTED TOPICS

  • 3
  • 3
  • 2
  • 1
  • 2
  • 2
  • 2
  • 2