pwntools을 설치했는데도 불구하고 오류가 발생합니다.


  • Level 3

    pwntools을 설치했는데도 불구하고 오류가 발생합니다.

    ModuleNotFoundError: No module named '_curses'

    파이썬 및 pwntools 모두 설치되어있는데 테스트만 해보면 이와 같은 오류가 발생합니다.

    구름 컨테이너에선 pwntools를 사용하지 못하는건가요?

    root@goorm:/workspace/pwn# pip3 install pwntools
    Requirement already satisfied: pwntools in /usr/local/lib/python3.7/site-packages (4.3.1)
    Requirement already satisfied: pyelftools>=0.2.4 in /usr/local/lib/python3.7/site-packages (from pwntools) (0.
    27)
    Requirement already satisfied: unicorn<1.0.2rc4,>=1.0.2rc1 in /usr/local/lib/python3.7/site-packages (from pwn
    tools) (1.0.2rc3)
    Requirement already satisfied: python-dateutil in /usr/local/lib/python3.7/site-packages (from pwntools) (2.8.
    1)
    Requirement already satisfied: packaging in /usr/local/lib/python3.7/site-packages (from pwntools) (20.4)
    Requirement already satisfied: pyserial>=2.7 in /usr/local/lib/python3.7/site-packages (from pwntools) (3.5)
    Requirement already satisfied: ropgadget>=5.3 in /usr/local/lib/python3.7/site-packages (from pwntools) (6.4)
    Requirement already satisfied: paramiko>=1.15.2 in /usr/local/lib/python3.7/site-packages (from pwntools) (2.7
    .2)
    Requirement already satisfied: pysocks in /usr/local/lib/python3.7/site-packages (from pwntools) (1.7.1)
    Requirement already satisfied: requests>=2.0 in /usr/local/lib/python3.7/site-packages (from pwntools) (2.24.0
    )
    Requirement already satisfied: pygments>=2.0 in /usr/local/lib/python3.7/site-packages (from pwntools) (2.7.2)
    Requirement already satisfied: psutil>=3.3.0 in /usr/local/lib/python3.7/site-packages (from pwntools) (5.8.0)
    Requirement already satisfied: intervaltree>=3.0 in /usr/local/lib/python3.7/site-packages (from pwntools) (3.
    1.0)
    Requirement already satisfied: mako>=1.0.0 in /usr/local/lib/python3.7/site-packages (from pwntools) (1.1.3)
    Requirement already satisfied: pip>=6.0.8 in /usr/local/lib/python3.7/site-packages (from pwntools) (21.0.1)
    Requirement already satisfied: capstone>=3.0.5rc2 in /usr/local/lib/python3.7/site-packages (from pwntools) (4
    .0.2)
    Requirement already satisfied: sortedcontainers in /usr/local/lib/python3.7/site-packages (from pwntools) (2.3
    .0)
    Requirement already satisfied: six>=1.12.0 in /usr/local/lib/python3.7/site-packages (from pwntools) (1.15.0)
    Requirement already satisfied: MarkupSafe>=0.9.2 in /usr/local/lib/python3.7/site-packages (from mako>=1.0.0->
    pwntools) (1.1.1)
    Requirement already satisfied: pynacl>=1.0.1 in /usr/local/lib/python3.7/site-packages (from paramiko>=1.15.2-

    pwntools) (1.4.0)
    Requirement already satisfied: bcrypt>=3.1.3 in /usr/local/lib/python3.7/site-packages (from paramiko>=1.15.2-
    pwntools) (3.2.0)
    Requirement already satisfied: cryptography>=2.5 in /usr/local/lib/python3.7/site-packages (from paramiko>=1.1
    5.2->pwntools) (3.3.1)
    Requirement already satisfied: cffi>=1.1 in /usr/local/lib/python3.7/site-packages (from bcrypt>=3.1.3->parami
    ko>=1.15.2->pwntools) (1.14.3)
    Requirement already satisfied: pycparser in /usr/local/lib/python3.7/site-packages (from cffi>=1.1->bcrypt>=3.
    1.3->paramiko>=1.15.2->pwntools) (2.20)
    Requirement already satisfied: chardet<4,>=3.0.2 in /usr/local/lib/python3.7/site-packages (from requests>=2.0
    ->pwntools) (3.0.4)
    Requirement already satisfied: urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 in /usr/local/lib/python3.7/site-packag
    es (from requests>=2.0->pwntools) (1.25.11)
    Requirement already satisfied: certifi>=2017.4.17 in /usr/local/lib/python3.7/site-packages (from requests>=2.
    0->pwntools) (2020.6.20)
    Requirement already satisfied: idna<3,>=2.5 in /usr/local/lib/python3.7/site-packages (from requests>=2.0->pwn
    tools) (2.10)
    Requirement already satisfied: pyparsing>=2.0.2 in /usr/local/lib/python3.7/site-packages (from packaging->pwn
    tools) (2.4.7)
    root@goorm:/workspace/pwn# python
    Python 3.7.4 (default, Nov 4 2020, 10:17:35)
    [GCC 7.4.0] on linux
    Type "help", "copyright", "credits" or "license" for more information.

    from pwn import *
    Traceback (most recent call last):
    File "<stdin>", line 1, in <module>
    File "/usr/local/lib/python3.7/site-packages/pwn/init.py", line 4, in <module>
    from pwn.toplevel import *
    File "/usr/local/lib/python3.7/site-packages/pwn/toplevel.py", line 20, in <module>
    import pwnlib
    File "/usr/local/lib/python3.7/site-packages/pwnlib/init.py", line 43, in <module>
    importlib.import_module('.%s' % module, 'pwnlib')
    File "/usr/local/lib/python3.7/importlib/init.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
    File "/usr/local/lib/python3.7/site-packages/pwnlib/args.py", line 62, in <module>
    from pwnlib import term
    File "/usr/local/lib/python3.7/site-packages/pwnlib/term/init.py", line 6, in <module>
    from pwnlib.term import completer
    File "/usr/local/lib/python3.7/site-packages/pwnlib/term/completer.py", line 7, in <module>
    from pwnlib.term import readline
    File "/usr/local/lib/python3.7/site-packages/pwnlib/term/readline.py", line 11, in <module>
    from pwnlib.term import keymap as km
    File "/usr/local/lib/python3.7/site-packages/pwnlib/term/keymap.py", line 4, in <module>
    from pwnlib.term import key
    File "/usr/local/lib/python3.7/site-packages/pwnlib/term/key.py", line 12, in <module>
    from pwnlib.term import termcap
    File "/usr/local/lib/python3.7/site-packages/pwnlib/term/termcap.py", line 6, in <module>
    from pwnlib.term.unix_termcap import get
    File "/usr/local/lib/python3.7/site-packages/pwnlib/term/unix_termcap.py", line 5, in <module>
    import curses
    File "/usr/local/lib/python3.7/curses/init.py", line 13, in <module>
    from _curses import *
    ModuleNotFoundError: No module named '_curses'

ONLINE USERS

POPULAR TOPICS

SUGGESTED TOPICS

  • 2
  • 2
  • 2
  • 3
  • 3
  • 2
  • 2
  • 2