안녕하세요 에러확인좀 부탁드릴게요 ㅠㅠ


  • Level 5

    Error parsing JSON: {
      "expo": {
        "name": "1st-cafe",
        "slug": "1st-cafe",
        "version": "1.0.0",
        "orientation": "portrait",
        "icon": "./assets/icon.png",
        "splash": {
          "image": "./assets/sp.png",
          "resizeMode": "contain",
          "backgroundColor": "#ffffff"
        },
        "updates": {
          "fallbackToCacheTimeout": 0
        },
        "assetBundlePatterns": [
          "**/*"
        ],
        "ios": {
          "supportsTablet": true
        },
        "android": {
          "adaptiveIcon": {
            "foregroundImage": "./assets/adaptive-icon.png",
            "backgroundColor": "#FFFFFF"
          }
        },
        "web": {
          "favicon": "./assets/favicon.png"
        },
        "packagerOpts": {
          "port": 51069
        }
      }
    }
    "ios": {
          "bundleIdentifier": "com.bw.1st_cafe",
          "buildNumber": "1.0.0"
            "supportsTablet": true
        },
        "android": {
          "package": "com.bw.1st_cafe",
          "versionCode": 1
        }
    ├─ File: /workspace/1st-cafe/app.json
    └─ Cause: SyntaxError: JSON5: invalid character '\"' at 36:1
      34 |   }
      35 | }
    > 36 | "ios": {
         | ^
      37 |       "bundleIdentifier": "com.bw.1st_cafe",
      38 |       "buildNumber": "1.0.0"
      39 |  "supportsTablet": true
        ├─ parseJsonString /usr/lib/node_modules/expo-cli/node_modules/@expo/json-file/src/JsonFile.ts:187:13
        ├─ read /usr/lib/node_modules/expo-cli/node_modules/@expo/json-file/src/JsonFile.ts:144:10
        ├─ getStaticConfig /usr/lib/node_modules/expo-cli/node_modules/@expo/config/src/getConfig.ts:41:27
        ├─ getConfig /usr/lib/node_modules/expo-cli/node_modules/@expo/config/src/Config.ts:94:52
        ├─ new BaseBuilder /usr/lib/node_modules/expo-cli/src/commands/build/BaseBuilder.ts:30:26
        ├─ new AndroidBuilder /usr/lib/node_modules/expo-cli/src/commands/build/AndroidBuilder.ts:19:16
        ├─ program.command.alias.helpGroup.option.option.option.option.option.option.option.option.option.option.description.asyncActionProjectDir.checkConfig /usr/lib/node_modules/expo-cli/src/commands/build/index.ts:1
    70:32
        └─ expo build:android /usr/lib/node_modules/expo-cli/src/exp.ts:350:7
    

    이렇게 뜨는데 어떤에러인지 ㅁ잘 모르겠어서 ㅠㅠ

  • Level 12

    @유덕호 메모리가 부족해서 빌드가 안되는 거 같습니다.
    프리미엄을 사용하시면 해결될 수도 있습니다.

  • Level 5

    @이기현-goorm
    답변감사합니다! 에러는 알려주신 답변으로 잘 해결되었는데
    expo build:android 를 하니

    Building JavaScript bundle [==========                                                      ] 15%
    <--- Last few GCs --->
    
    [3281:0x4db8540]   356910 ms: Mark-sweep (reduce) 506.7 (516.1) -> 504.8 (516.0) MB, 6903.7 / 0.1 ms  (average mu = 0.158, current mu = 0.043) allocation failure scavenge might not succeed
    [3281:0x4db8540]   364111 ms: Mark-sweep (reduce) 506.2 (513.7) -> 505.7 (515.2) MB, 6795.4 / 0.0 ms  (average mu = 0.109, current mu = 0.056) allocation failure scavenge might not succeed
    
    
    <--- JS stacktrace --->
    
    FATAL ERROR: Ineffective mark-compacts near heap limit Allocation failed - JavaScript heap out of memory
     1: 0xa222f0 node::Abort() [node]
     2: 0x96411f node::FatalError(char const*, char const*) [node]
     3: 0xb97f1e v8::Utils::ReportOOMFailure(v8::internal::Isolate*, char const*, bool) [node]
     4: 0xb98297 v8::internal::V8::FatalProcessOutOfMemory(v8::internal::Isolate*, char const*, bool) [node]
     5: 0xd52fd5  [node]
     6: 0xd53b5f  [node]
     7: 0xd61beb v8::internal::Heap::CollectGarbage(v8::internal::AllocationSpace, v8::internal::GarbageCollectionReason, v8::GCCallbackFlags) [node]
     8: 0xd657ac v8::internal::Heap::AllocateRawWithRetryOrFailSlowPath(int, v8::internal::AllocationType, v8::internal::AllocationOrigin, v8::internal::AllocationAlignment) [node]
     9: 0xd33e5b v8::internal::Factory::NewFillerObject(int, bool, v8::internal::AllocationType, v8::internal::AllocationOrigin) [node]
    10: 0x107c5af v8::internal::Runtime_AllocateInYoungGeneration(int, unsigned long*, v8::internal::Isolate*) [node]
    11: 0x1423279  [node]
    중지됨 (core dumped)
    

    이런 에러가 뜨는데 양이 좀 많네요..
    뭐가 문제인지 알수있을까요..??
    뭔가 힙 메모리 부족? 이라고 나오는거 같긴한데..확실히 모르겠네요 ㅠ

  • Level 12

    @유덕호
    JSON 구조가 잘못되어 있었던거 같습니다.
    아래와 같이 하면 될거 같네요 🙂

    {
    	"expo": {
    		"name": "1st-cafe",
    		"slug": "1st-cafe",
    		"version": "1.0.0",
    		"orientation": "portrait",
    		"icon": "./assets/icon.png",
    		"splash": {
    			"image": "./assets/sp.png",
    			"resizeMode": "contain",
    			"backgroundColor": "#ffffff"
    		},
    		"updates": {
    			"fallbackToCacheTimeout": 0
    		},
    		"assetBundlePatterns": [
    			"**/*"
    		],
    		"android": {
    			"package": "com.bw.1st_cafe",
    			"versionCode": 1,
    			"adaptiveIcon": {
    				"foregroundImage": "./assets/adaptive-icon.png",
    				"backgroundColor": "#FFFFFF"
    			}
    		},
    		"web": {
    			"favicon": "./assets/favicon.png"
    		},
    		"ios": {
    			"bundleIdentifier": "com.BW.1st_cafe",
    			"buildNumber": "1.0.0",
    			"supportsTablet": true
    		},
    		"packagerOpts": {
    			"port": 51069
    		}
    	}
    }
    
  • Level 5

    @이기현-goorm

    {
      "expo": {
        "name": "1st-cafe",
        "slug": "1st-cafe",
        "version": "1.0.0",
        "orientation": "portrait",
        "icon": "./assets/icon.png",
        "splash": {
          "image": "./assets/sp.png",
          "resizeMode": "contain",
          "backgroundColor": "#ffffff"
        },
        "updates": {
          "fallbackToCacheTimeout": 0
        },
        "assetBundlePatterns": [
          "**/*"
    		],
        "android": {
          "adaptiveIcon": {
            "foregroundImage": "./assets/adaptive-icon.png",
            "backgroundColor": "#FFFFFF"
          }
        },
        "web": {
          "favicon": "./assets/favicon.png"
        },
        "packagerOpts": {
          "port": 51069
        }
      }
    },
    "ios": {
    		"bundleIdentifier": "com.BW.1st_cafe",
    		"buildNumber": "1.0.0",
    		"supportsTablet": true
        },
        "android": {
          	"package": "com.bw.1st_cafe",
          	"versionCode": 1
        }
    

    현재 코드입니다 ㅠㅠ

  • Level 12

    JSON 전부를 볼 수 있을까요?
    중괄호 짝이 안맞아서 그럴 수도 있을 거 같습니다.

  • Level 5

    감사합니다 알려주신대로 해보았는데```
    }
    ├─ File: /workspace/1st-cafe/app.json
    └─ Cause: SyntaxError: JSON5: invalid character ',' at 32:2
    30 | }
    31 | }

    32 | },
    | ^
    33 | "ios": {
    34 | "bundleIdentifier": "com.BW.1st_cafe",
    35 | "buildNumber": "1.0.0",

    , 찍은 곳에 에러가 있다고 뜨는것같네요 위에서부터 뭔가 잘못된걸까요..??
  • Level 12

    안녕하세요.

    }
    "ios":
    

    },
    "ios":
    

    로 바꾸시면 해결 될거 같습니다. 🙂

SUGGESTED TOPICS

  • 4
  • 1
  • 2
  • 12
  • 2
  • 2
  • 3