java 11 지원 관련


  • Level 3

    안녕하세요,
    goorm ide를 이용하여 spring boot를 공부하고자 하는 한 학생입니다.

    goorm ide가 아니면 실습이 어려운 환경에 있는데 많은 spring 관련 자료들이 java 11을 기준으로 작성되어 학습하는데 어려움을 겪고 있습니다. goorm ide에서 현재 java 8, 9까지 지원하는 것으로 알고있는데 혹시 11은 언제쯤 지원되는지 문의드립니다.

    감사합니다

  • Level 3

    @배명호-goorm 님이 java 11 지원 관련 에서 보낸 메세지:

    javac -version

    답변 감사합니다!

  • Level 12

    안녕하세요. kkks님

    최신 버전의 언어 지원은 내부적으로 검토 후에 진행할 예정입니다. 실제 적용까지 다소 시간이 걸릴 수 있는 점 양해 부탁드립니다.

    추가로, 자바 11 버전을 설치할 수 있는 방법을 안내드립니다. 아래 순서대로 시도해 보시길 바랍니다!

    # apt-get 업데이트
    sudo apt-get update && sudo apt-get upgrade
    
    # java 11 설치
    sudo apt-get install openjdk-11-jdk
    
    # java 11 적용. 아래 명령어 입력후 11 버전에 해당하는 번호를 입력하고 엔터 키를 누르세요.
    sudo update-alternatives --config java
    sudo update-alternatives --config javac
    
    # 버전 확인
    javac -version
    java -version
    

ONLINE USERS

POPULAR TOPICS

SUGGESTED TOPICS