[rails] 구름IDE에서 만든 프로젝트를 다른 IDE에서 실행하고싶습니다.


  • Level 4

    일단 구름IDE에서 만든 것을 git에 push하고 다른 컴퓨터에서 clone하고 bundle install까지는 성공했습니다.

    그런데 막상 실행을 하면 에러가 뜨는데 어떤 부분을 고쳐야할지 모르겠습니다 ㅠㅠ

    현재 사용중인 IDE는 rubymine이며 에러 내용은 다음과 같습니다.

    /bin/zsh -c "bash -c 'env RBENV_VERSION=2.6.5 /opt/homebrew/Cellar/rbenv/1.2.0/libexec/rbenv exec ruby -x /Users/ljws93/RubymineProjects/goorm_rails_test/bin/bundle exec ruby /Users/ljws93/RubymineProjects/goorm_rails_test/bin/rails server -b 0.0.0.0 -p 3000 -e development'"
    Traceback (most recent call last):
    98: from /Users/ljws93/RubymineProjects/goorm_rails_test/bin/rails:3:in <main>' 97: from /Users/ljws93/RubymineProjects/goorm_rails_test/bin/rails:3:inload'
    96: from /Users/ljws93/RubymineProjects/goorm_rails_test/bin/spring:15:in <top (required)>' 95: from /Users/ljws93/RubymineProjects/goorm_rails_test/bin/spring:15:inrequire'
    94: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/spring-2.1.0/lib/spring/binstub.rb:11:in <top (required)>' 93: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/spring-2.1.0/lib/spring/binstub.rb:11:inload'
    92: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/spring-2.1.0/bin/spring:49:in <top (required)>' 91: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/spring-2.1.0/lib/spring/client.rb:30:inrun'
    90: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/spring-2.1.0/lib/spring/client/command.rb:7:in call' 89: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/spring-2.1.0/lib/spring/client/rails.rb:28:incall'
    88: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/spring-2.1.0/lib/spring/client/rails.rb:28:in load' 87: from /Users/ljws93/RubymineProjects/goorm_rails_test/bin/rails:9:in<top (required)>'
    86: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/activesupport-6.0.3.2/lib/active_support/dependencies.rb:324:in require' 85: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/activesupport-6.0.3.2/lib/active_support/dependencies.rb:291:inload_dependency'
    84: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/activesupport-6.0.3.2/lib/active_support/dependencies.rb:324:in block in require' 83: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:31:inrequire'
    82: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:in require_with_bootsnap_lfi' 81: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/loaded_features_index.rb:92:inregister'
    80: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:23:in block in require_with_bootsnap_lfi' 79: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:23:inrequire'
    78: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/railties-6.0.3.2/lib/rails/commands.rb:18:in <main>' 77: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/railties-6.0.3.2/lib/rails/command.rb:46:ininvoke'
    76: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/railties-6.0.3.2/lib/rails/command/base.rb:69:in perform' 75: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/thor-1.0.1/lib/thor.rb:392:indispatch'
    74: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/thor-1.0.1/lib/thor/invocation.rb:127:in invoke_command' 73: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/thor-1.0.1/lib/thor/command.rb:27:inrun'
    72: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/railties-6.0.3.2/lib/rails/commands/server/server_command.rb:138:in perform' 71: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/railties-6.0.3.2/lib/rails/commands/server/server_command.rb:138:intap'
    70: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/railties-6.0.3.2/lib/rails/commands/server/server_command.rb:141:in block in perform' 69: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/activesupport-6.0.3.2/lib/active_support/dependencies.rb:324:inrequire'
    68: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/activesupport-6.0.3.2/lib/active_support/dependencies.rb:291:in load_dependency' 67: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/activesupport-6.0.3.2/lib/active_support/dependencies.rb:324:inblock in require'
    66: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:31:in require' 65: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:inrequire_with_bootsnap_lfi'
    64: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/loaded_features_index.rb:92:in register' 63: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:23:inblock in require_with_bootsnap_lfi'
    62: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:23:in require' 61: from /Users/ljws93/RubymineProjects/goorm_rails_test/config/application.rb:7:in<main>'
    60: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bundler-2.3.11/lib/bundler.rb:176:in require' 59: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bundler-2.3.11/lib/bundler/runtime.rb:44:inrequire'
    58: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bundler-2.3.11/lib/bundler/runtime.rb:44:in each' 57: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bundler-2.3.11/lib/bundler/runtime.rb:55:inblock in require'
    56: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bundler-2.3.11/lib/bundler/runtime.rb:55:in each' 55: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bundler-2.3.11/lib/bundler/runtime.rb:60:inblock (2 levels) in require'
    54: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:31:in require' 53: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:inrequire_with_bootsnap_lfi'
    52: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/loaded_features_index.rb:92:in register' 51: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:23:inblock in require_with_bootsnap_lfi'
    50: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:23:in require' 49: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/sass-rails-6.0.0/lib/sass-rails.rb:1:in<main>'
    48: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/activesupport-6.0.3.2/lib/active_support/dependencies.rb:324:in require' 47: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/activesupport-6.0.3.2/lib/active_support/dependencies.rb:291:inload_dependency'
    46: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/activesupport-6.0.3.2/lib/active_support/dependencies.rb:324:in block in require' 45: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:31:inrequire'
    44: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:in require_with_bootsnap_lfi' 43: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/loaded_features_index.rb:92:inregister'
    42: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:23:in block in require_with_bootsnap_lfi' 41: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:23:inrequire'
    40: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/sassc-rails-2.1.2/lib/sassc/rails.rb:5:in <main>' 39: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/activesupport-6.0.3.2/lib/active_support/dependencies.rb:324:inrequire'
    38: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/activesupport-6.0.3.2/lib/active_support/dependencies.rb:291:in load_dependency' 37: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/activesupport-6.0.3.2/lib/active_support/dependencies.rb:324:inblock in require'
    36: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:31:in require' 35: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:inrequire_with_bootsnap_lfi'
    34: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/loaded_features_index.rb:92:in register' 33: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:23:inblock in require_with_bootsnap_lfi'
    32: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:23:in require' 31: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/sassc-2.4.0/lib/sassc.rb:31:in<main>'
    30: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:49:in require_relative' 29: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/activesupport-6.0.3.2/lib/active_support/dependencies.rb:324:inrequire'
    28: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/activesupport-6.0.3.2/lib/active_support/dependencies.rb:291:in load_dependency' 27: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/activesupport-6.0.3.2/lib/active_support/dependencies.rb:324:inblock in require'
    26: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:31:in require' 25: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:inrequire_with_bootsnap_lfi'
    24: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/loaded_features_index.rb:92:in register' 23: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:23:inblock in require_with_bootsnap_lfi'
    22: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:23:in require' 21: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/sassc-2.4.0/lib/sassc/native.rb:5:in<main>'
    20: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/sassc-2.4.0/lib/sassc/native.rb:6:in <module:SassC>' 19: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/sassc-2.4.0/lib/sassc/native.rb:16:inmodule:Native'
    18: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:49:in require_relative' 17: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/activesupport-6.0.3.2/lib/active_support/dependencies.rb:324:inrequire'
    16: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/activesupport-6.0.3.2/lib/active_support/dependencies.rb:291:in load_dependency' 15: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/activesupport-6.0.3.2/lib/active_support/dependencies.rb:324:inblock in require'
    14: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:31:in require' 13: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:inrequire_with_bootsnap_lfi'
    12: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/loaded_features_index.rb:92:in register' 11: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:23:inblock in require_with_bootsnap_lfi'
    10: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/bootsnap-1.4.6/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:23:in require' 9: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/sassc-2.4.0/lib/sassc/native/sass_value.rb:3:in<main>'
    8: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/sassc-2.4.0/lib/sassc/native/sass_value.rb:4:in <module:SassC>' 7: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/sassc-2.4.0/lib/sassc/native/sass_value.rb:52:inmodule:Native'
    6: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/sassc-2.4.0/lib/sassc/native/sass_value.rb:53:in <class:SassList>' 5: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/ffi-1.13.1/lib/ffi/struct.rb:217:inlayout'
    4: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/ffi-1.13.1/lib/ffi/struct.rb:311:in array_layout' 3: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/ffi-1.13.1/lib/ffi/struct.rb:271:infind_field_type'
    2: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/ffi-1.13.1/lib/ffi/struct.rb:277:in find_type' 1: from /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/ffi-1.13.1/lib/ffi/library.rb:589:infind_type'
    /Users/ljws93/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/ffi-1.13.1/lib/ffi/types.rb:69:in `find_type': unable to resolve type 'size_t' (TypeError)

    Process finished with exit code 1

  • Level 4

    @joony-kwon
    감사합니다!

  • Level 5

    안녕하세요.

    ffi 라이브러리의 문제로 보입니다. 현재 설치된 ffi 버전인 1.13.0에서는 특수한 환경 (맥북 M1 등)에서 문제가 발생할 수 있다고 합니다. 자세한 원인은 알 수 없지만, 버전을 업데이트하면 문제가 해결될 수 있을 것 같습니다.

    혹은 Gemfile.lock 파일을 제거하고 다시 bundle install을 진행하시면 라이브러리가 최신 버전으로 설치됩니다.

ONLINE USERS

POPULAR TOPICS

SUGGESTED TOPICS