Firebase CLI 사용할 때 무조건 최신 버전 쓰지 마세요. (해결 가이드)


  • Level 4

    보통 이 명령어로 많이 설치할텐데 이제 이거 안 됩니다.

    npm install -g firebase-tools
    

    왜냐면 NodeJS 버전이 16.x 로 고정되어 있는 현재 구름IDE 에서는 더 이상 이용할 수 없기 때문입니다. 그런데 이전까지는 동작했단 말이죠?

    결론은, 최신 버전을 설치하면서 사용할 수 없는 문제가 발생하니, firebase-tools 를 구버전을 설치하고 그 다음에 최신 버전으로 다시 업데이트 하는 것이 좋습니다.

    https://www.npmjs.com/package/firebase-tools?activeTab=versions

    여기서 버전 목록을 모두 확인할 수 있는데, 추천하는 버전은 12.9.1 입니다.

    npm install -g firebase-tools@12.9.1
    

    그러면 이제 Firebase 모든 기능들이 정상 설치되는 걸 볼 수 있습니다.
    아 근데, 여기서 바로 업데이트 하시면 절대 안 됩니다.
    반드시 로그인을 마치고 기본 설정이 모두 끝난 뒤에 업데이트를 진행하시기 바랍니다.
    (물론 잘 될지는 의문…)

    로그인 하실 때는

    firebase login --no-localhost
    

    를 사용해서 터미널의 주소를 복사하여 링크를 복사한 뒤에 로그인 해야 됩니다.
    당연 firebase init 도 해야되고, 각종 설정을 모두 다 마치시는 것도 잊지 마시구요.

ONLINE USERS

POPULAR TOPICS

SUGGESTED TOPICS