구름IDE에서 한글입력이 안됩니다.


  • Level 3

    안녕하세요.
    크롬으로 콘테이너-구름IDE사용중 데이터의 한글 내용이 입력이 안되고 빈 칸으로 보이는데요.
    사진과 같이 한글 입력이 가능한 데이터베이스를 생성해서 사용하는데
    1111.PNG 111.PNG

    OS문제도 있다고 하여 데스크탑, 노트북에서 같은 방식으로 하는데 안되네요.

    답변 부탁드립니다.

  • Level 3

    @joony-kwon 감사합니다. export LANG=ko_KR.UTF-8 을 진행했더니, 다시 접속해도 되는군요. 감사합니다.

  • Level 5

    @Y-G-Yeo

    안녕하세요.

    문제가 해결되어 다행입니다. 터미널 실행 시 환경 변수를 매번 지정해야 한다면, 아래 화면처럼 설정 - 터미널 - 프로필 우측 에디터 하단에 아래 내용을 추가해주세요.

    export LANG=ko_KR.UTF-8
    

    53034876-d91d-4b58-b7b5-0b168bd1debd-image.png

  • Level 3

    일단 root에서
    LANG=ko_KR.UTF8 입력후 사용하면 가능하네요.
    그런데 로그아웃후 다시 들어가면 같은현상
    그래서 다시 LANG=ko_KR.UTF8 입력하고 사용합니다.

  • Level 3

    @joony-kwon !

    11.PNG
    답변감사합니다. 웹 블로그 게시글로 체크해 보니,

    root에서는 그림과 같이 한글 입력이 되는데요.

    service mysql start
    mysql -uroot -p 로 제 작업공간에 들어가면
    역시 한글입력이 안되는데요.

    일단 제 노트북과 데스크탑에서는 같은 현상인데,
    제가 다른 장소에서 데스크탑을 이용해서 같은 구름 콘테이너에서
    로그인하여 작업해보면 한글입력이 되고 보이네요.

    제 컴이나 OS에 어떤 문제가 있는걸가요? 크롬, 엣지등에서 같은 현상.

    그런데
    locale로 보면 답글의 내용에서는
    LC_CTYPE="ko_KR.UTF-8"
    LC_NUMERIC="ko_KR.UTF-8"
    LC_TIME="ko_KR.UTF-8"
    LC_COLLATE="ko_KR.UTF-8"
    LC_MONETARY="ko_KR.UTF-8"
    LC_MESSAGES="ko_KR.UTF-8"
    LC_PAPER="ko_KR.UTF-8"
    LC_NAME="ko_KR.UTF-8"
    LC_ADDRESS="ko_KR.UTF-8"
    LC_TELEPHONE="ko_KR.UTF-8"
    LC_MEASUREMENT="ko_KR.UTF-8"
    LC_IDENTIFICATION="ko_KR.UTF-8" 인데,
    제가 첨부한 파일은 en_US.UTF-8로 보이는게 어떤 차이가 있는지?
    해결이 안되었습니다.

  • Level 5

    안녕하세요.

    IDE에 내장된 터미널에서는 자동으로 로케일 설정을 통해 한글 입력이 가능하도록 처리하고 있습니다. 다만 IDE에 내장된 터미널이 아닌 다른 터미널을 사용하신다면, 한글 입력이 정상적으로 동작하지 않을 수 있습니다. 이런 경우에는 터미널 프로필을 설정해야할 수 있습니다. 로케일 설정과 관련된 웹 블로그 게시글을 전달해드립니다. 도움이 되셨으면 좋겠습니다.

    만약 IDE에 내장된 터미널을 사용해도 한글 입력이 동작하지 않는다면, 다시 댓글 남겨주시기 바랍니다!

ONLINE USERS

POPULAR TOPICS

SUGGESTED TOPICS